‹ Back to Splice

My D16 Plugin is saying my plan is expired. What should I do?

Follow
 

Screen_Shot_2018-03-14_at_1.52.44_PM.png

 

Please make sure that you are signed into the Splice desktop client with an account that has a D16 Plugin plan active before you open up your DAW to load your D16 Plugin. While you are on the Rent-to-Own plan, the client needs to verify the D16 plugin once every few days.

If your plan is active and Splice app is open, please try logging out of the Splice app and log back in.  Relaunch your DAW and initiate a new instance of your D16 plugin.

This fix may also apply to users being prompted for a serial number.

If issues persist, please contact support@splice.com.

 

 

  

 

 

Have more questions? Submit a request

Comments